Technical requirements

Last updated: September 20, 2021

Browser

The platform supports the following browsers:

Browser Full support Partial support No support
Chrome Latest version 49 or newer 48 or older
Edge Latest version 79 or newer
Firefox Latest version 45 or newer 44 or older
Opera Latest version 36 or newer 35 or older
Safari Latest version 9 or newer 8 or older
Edge Legacy EdgeHTML 18 17 or older
Internet Explorer 11 10 9 or older

Certain features may have stricter browser requirements. See the section on feature compatibility below for more information. For the best possible experience, use the latest version of Chrome, Edge, Firefox, Opera, or Safari.

Some alternative browsers use the same rendering engine as Chrome, Firefox, and Safari. These browsers are generally the same as the version of Chrome, Firefox, and Safari that they are based on. Alternative browsers using a supported engine version are considered partially supported.

JavaScript must be enabled.

Cookies must be enabled. We use cookies for storing data related to authentication and user preferences.

Support policy

Full support: We actively test the platform using these browsers.

Partial support: We do not actively test the platform using these browsers. We will investigate any problems as they are reported to us. There are generally no issues with using slightly older versions. Very old browsers may not be compatible with all features.

No support: We do not provide any support for these browsers. These browsers have long since been unsupported by their vendors and lack support for fundamental web technologies.

Feature compatibility

Most features of the platform are compatible in all supported browsers. However, some features require more recent web technologies which may not be available in all of these browsers. If a browser lacks some underlying functionality required by a feature, then that feature is not supported in that browser.

The following is a list of known incompatibilities:

  • PDFs embedded in courses are not supported by Internet Explorer or mobile browsers. In order to view these PDFs, they must be opened in a separate application which must be installed on the device.

  • Rich-text editing (such as editing courses) is not supported in Internet Explorer 10.

  • The Page Builder and course content saved by the Page Builder are not supported in Internet Explorer.

  • Virtual classes are not supported in Edge Legacy or Internet Explorer.

Hardware

Generally, if your device was manufactured within the last 10 years, it should be fine in terms of computing power. For older hardware, we recommend the following minimum specifications:

CPU clock speed
1 GHz
RAM
512 MB

The platform is compatible with tablets and phones.

Software

Courses may provide downloadable files, such as Word documents or PDFs. Appropriate software must be installed on a device before these types of files can be viewed.

Browser extensions, plugins, toolbars, add-ons, and other such software may interfere with platform functionality.

Viruses and malware can prevent the platform from functioning and damage your data. Ensure your system is protected by using protective software such as anti-virus or anti-malware software.

Network

An active Internet connection is required at all times.

The platform can be used in environments that use a firewall or VPN, or configure browser and network settings in a centralized manner (such as Group Policy). However, it is possible that restrictions can impact the performance and functionality of the platform if improperly configured.

The platform is hosted on the following domains. You may use a branded subdomain on one of these domains. The domain you use must be fully accessible.

  • znanja.com
  • constantlearning.net
  • extrify.com
  • staffelearning.com
  • velocitylms.com

The platform makes requests to resources hosted on the following domains. These domains must be fully accessible.

  • amazonaws.com
  • cloudflare.com
  • googleapis.com
  • gstatic.com
  • jsdelivr.net

The platform makes requests to the following domains for performance and error monitoring:

  • newrelic.com
  • nr-data.net
  • ravenjs.com
  • sentry.io

The platform makes requests to the following domains for marketing purposes:

  • doubleclick.net
  • google-analytics.com
  • googletagmanager.com

Custom domains

You can serve the platform on your own domain. This requires being able to change the DNS settings for your domain, and you must provide a valid TLS (SSL) certificate.

Embedding the platform in an iframe to bypass this security requirement is not supported.

SCORM

SCORM content imported into the platform must be SCORM 1.2 compliant.

Courses are exported from the platform as SCORM 1.2 packages. In order to use these packages in your own LMS, your LMS must be SCORM 1.2 compliant. Our technical requirements apply when viewing the content in your LMS.


Courses and custom pages in the platform are free to use any available browser technologies which may impose additional requirements on a case-by-case basis.